about summary refs log tree commit diff stats
path: root/templates/awk/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-03-31 17:04:59 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-03-31 23:59:54 +0200
commit3094a6bef6aa83fd0321caec58ce402ae7609899 (patch)
tree34e23af608a5877cd3275a842c392c68017483d2 /templates/awk/flake.nix
parentfeat(c): Update to be in line with the my SOTA (diff)
downloadflake-templates-3094a6bef6aa83fd0321caec58ce402ae7609899.tar.gz
flake-templates-3094a6bef6aa83fd0321caec58ce402ae7609899.zip
feat(awk): Update to my current SOTA
Diffstat (limited to 'templates/awk/flake.nix')
-rw-r--r--templates/awk/flake.nix100
1 files changed, 100 insertions, 0 deletions
diff --git a/templates/awk/flake.nix b/templates/awk/flake.nix
new file mode 100644
index 0000000..aeacf3b
--- /dev/null
+++ b/templates/awk/flake.nix
@@ -0,0 +1,100 @@
+{
+  description = "TODO";
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
+    flake_version_update = {
+      url = "git+https://codeberg.org/soispha/flake_version_update.git";
+      inputs = {
+        systems.follows = "systems";
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+
+    # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-compat = {
+      url = "github:edolstra/flake-compat";
+      flake = false;
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+  };
+
+  outputs = {
+    self,
+    nixpkgs,
+    flake-utils,
+    treefmt-nix,
+    flake_version_update,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages.${system};
+      treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
+
+      # This version is set automatically on `cog bump --auto`;
+      version = "v1.0.0"; # GUIDING VERSION STRING
+
+      man_number = "1"; # TODO change if necessary
+      pname = "TODO";
+    in {
+      packages.default = pkgs.stdenv.mkDerivation {
+        inherit version pname;
+        src = ./.;
+
+        nativeBuildInputs = with pkgs; [pandoc fd];
+
+        dependencies = with pkgs; [gawk];
+
+        buildPhase = ''
+          mkdir --parents $out/docs;
+          pandoc ./docs/${pname}.${man_number}.md -s -t man  > $out/docs/${pname}.${man_number}
+        '';
+
+        installPhase = ''
+          install -D $out/docs/${pname}.${man_number}  $out/share/man/man${man_number}/${pname};
+
+          install -D ./src/${pname}.awk $out/bin/${pname}.awk;
+
+          # Generate a wrapper script.
+          cat << EOF > $out/bin/${pname}
+          #! /usr/bin/env sh
+          $out/bin/${pname}.awk -- "\$@"
+          EOF
+
+          # Set correct permissions
+          chmod +x $out/bin/${pname}
+        '';
+      };
+
+      checks.formatting = treefmtEval.config.build.check self;
+      formatter = treefmtEval.config.build.wrapper;
+
+      devShells.default = pkgs.mkShell {
+        packages = with pkgs; [
+          cocogitto
+          flake_version_update.packages."${system}".default
+
+          gawk
+        ];
+      };
+    });
+}
+# vim: ts=2
+