about summary refs log tree commit diff stats
path: root/rust/default.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-27 16:47:17 +0200
committerSoispha <soispha@vhack.eu>2023-05-27 16:47:17 +0200
commit1f263a83a6f7d7dd1898326b04b2491b78e845b1 (patch)
treee56f9e121b8d904033fc9b21065ab0c9b242fb74 /rust/default.nix
parentChore: Initial Commit (diff)
downloadflake-templates-1f263a83a6f7d7dd1898326b04b2491b78e845b1.tar.gz
flake-templates-1f263a83a6f7d7dd1898326b04b2491b78e845b1.zip
Feat(rust): Update
Diffstat (limited to 'rust/default.nix')
-rw-r--r--rust/default.nix42
1 files changed, 0 insertions, 42 deletions
diff --git a/rust/default.nix b/rust/default.nix
deleted file mode 100644
index 75e6b2a..0000000
--- a/rust/default.nix
+++ /dev/null
@@ -1,42 +0,0 @@
-{
-  description = ""; # TODO fill
-
-  inputs = {
-    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-    flake-utils.url = "github:numtide/flake-utils";
-
-    crane = {
-      url = "github:ipetkov/crane";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
-      };
-    };
-  };
-
-  outputs = {
-    self,
-    nixpkgs,
-    crane,
-    flake-utils,
-    ...
-  }:
-    flake-utils.lib.eachDefaultSystem (system: let
-      craneLib = crane.lib.${system};
-      craneBuild = craneLib.buildPackage {
-        src = craneLib.cleanCargoSource ./.;
-
-        doCheck = true;
-      };
-      appName = ""; # TODO fill
-    in {
-      packages.default = craneBuild;
-      legacyPackages.default = craneBuild;
-      app.default = {
-        type = "app";
-        program = "${self.packages.${system}.default}/bin/${appName}";
-      };
-    });
-}
-# vim: ts=2
-