about summary refs log tree commit diff stats
path: root/latex/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-06-18 17:00:18 +0200
committerSoispha <soispha@vhack.eu>2023-06-18 17:00:18 +0200
commit4c368a27800900e5c3afd3e03d43d6d379bc471a (patch)
treea8aa66cb46a6cda39b0b6f0a535ec084bbf2821d /latex/flake.nix
parentFix(.gitigonore): Ignore specific files in templates (diff)
downloadflake-templates-4c368a27800900e5c3afd3e03d43d6d379bc471a.tar.gz
flake-templates-4c368a27800900e5c3afd3e03d43d6d379bc471a.zip
Feat(latex): Init
Diffstat (limited to 'latex/flake.nix')
-rw-r--r--latex/flake.nix105
1 files changed, 105 insertions, 0 deletions
diff --git a/latex/flake.nix b/latex/flake.nix
new file mode 100644
index 0000000..f3f7879
--- /dev/null
+++ b/latex/flake.nix
@@ -0,0 +1,105 @@
+{
+  description = ""; # TODO
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+    # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-compat = {
+      url = "github:edolstra/flake-compat";
+      flake = false;
+    };
+    crane = {
+      url = "github:ipetkov/crane";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+      };
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+    rust-overlay = {
+      url = "github:oxalica/rust-overlay";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+
+    # bins
+    flake_version_update = {
+      url = "git+https://codeberg.org/soispha/flake_version_update.git";
+      inputs = {
+        systems.follows = "systems";
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+    lpm = {
+      url = "git+https://codeberg.org/Soispha/lpm.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+      };
+    };
+  };
+
+  outputs = {
+    nixpkgs,
+    flake-utils,
+    flake_version_update,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages.${system};
+
+      # This version is set automatically on `cog bump --auto`;
+      version = "v1.0.0"; # GUIDING VERSION STRING
+
+      texlive = pkgs.texlive.combined.small;
+    in {
+      packages.default = pkgs.stdenv.mkDerivation {
+        pname = ""; # TODO
+        inherit version;
+        src = ./.;
+
+        buildInputs = [
+          texlive
+        ];
+
+        buildPhase = ''
+          latexmk -file-line-error main.tex
+        '';
+
+        installPhase = ''
+          install -D $scr/build/*.pdf $out/;
+        '';
+      };
+      devShells.default = pkgs.mkShell {
+        packages = with pkgs; [
+          nil
+          alejandra
+          statix
+          ltex-ls
+          cocogitto
+          flake_version_update.packages."${system}".default
+          lpm.packages."${system}".default
+
+          texlab
+          zathura
+        ];
+      };
+    });
+}
+# vim: ts=2
+