about summary refs log tree commit diff stats
path: root/latex/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-03-31 23:10:25 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-04-01 00:00:00 +0200
commitff14f9474303784518589fd0ea1ad4b44dbc7161 (patch)
treef57e0192e5d0b8461aa306fd52a9d102fb927508 /latex/flake.nix
parentfeat(rust): Update to my SOTA (diff)
downloadflake-templates-ff14f9474303784518589fd0ea1ad4b44dbc7161.tar.gz
flake-templates-ff14f9474303784518589fd0ea1ad4b44dbc7161.zip
feat(latex): Update to my current SOTA
Diffstat (limited to 'latex/flake.nix')
-rw-r--r--latex/flake.nix103
1 files changed, 0 insertions, 103 deletions
diff --git a/latex/flake.nix b/latex/flake.nix
deleted file mode 100644
index 52f7353..0000000
--- a/latex/flake.nix
+++ /dev/null
@@ -1,103 +0,0 @@
-{
-  description = ""; # TODO
-
-  inputs = {
-    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
-    # inputs for following
-    systems = {
-      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
-    };
-    flake-compat = {
-      url = "github:edolstra/flake-compat";
-      flake = false;
-    };
-    crane = {
-      url = "github:ipetkov/crane";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
-        rust-overlay.follows = "rust-overlay";
-      };
-    };
-    flake-utils = {
-      url = "github:numtide/flake-utils";
-      inputs = {
-        systems.follows = "systems";
-      };
-    };
-    rust-overlay = {
-      url = "github:oxalica/rust-overlay";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
-      };
-    };
-
-    # bins
-    flake_version_update = {
-      url = "git+https://codeberg.org/soispha/flake_version_update.git";
-      inputs = {
-        systems.follows = "systems";
-        nixpkgs.follows = "nixpkgs";
-        flake-utils.follows = "flake-utils";
-      };
-    };
-    lpm = {
-      url = "git+https://codeberg.org/Soispha/lpm.git";
-      inputs = {
-        nixpkgs.follows = "nixpkgs";
-        flake-compat.follows = "flake-compat";
-        flake-utils.follows = "flake-utils";
-        rust-overlay.follows = "rust-overlay";
-      };
-    };
-  };
-
-  outputs = {
-    nixpkgs,
-    flake-utils,
-    flake_version_update,
-    lpm,
-    ...
-  }:
-    flake-utils.lib.eachDefaultSystem (system: let
-      pkgs = nixpkgs.legacyPackages.${system};
-
-      # This version is set automatically on `cog bump --auto`;
-      version = "v1.0.0"; # GUIDING VERSION STRING
-
-      # TODO reduce to the needed ones
-      texlive = pkgs.texlive.combined.scheme-full;
-    in {
-      packages.default = pkgs.stdenv.mkDerivation {
-        pname = ""; # TODO
-        inherit version;
-        src = ./.;
-
-        buildInputs = [
-          texlive
-        ];
-
-        buildPhase = ''
-          latexmk -file-line-error main.tex
-        '';
-
-        installPhase = ''
-          install -D $scr/build/*.pdf $out/;
-        '';
-      };
-      devShells.default = pkgs.mkShell {
-        packages = with pkgs; [
-          cocogitto
-          flake_version_update.packages."${system}".default
-          lpm.packages."${system}".default
-          texlive
-
-          zathura
-        ];
-      };
-    });
-}
-# vim: ts=2
-