about summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
authorSoispha <soispha@vhack.eu>2023-05-28 14:48:59 +0200
committerSoispha <soispha@vhack.eu>2023-05-28 14:48:59 +0200
commit00516e3f61c6c7e3ba4cfd04aa7c818e955494ab (patch)
tree851666809a029ae9c7df93d5a1fb0e513a325e05 /flake.nix
parentBuild(cog): Rename NEWS to NEWS.md as it's markdown (diff)
downloadflake-templates-00516e3f61c6c7e3ba4cfd04aa7c818e955494ab.tar.gz
flake-templates-00516e3f61c6c7e3ba4cfd04aa7c818e955494ab.zip
Fix(flake): Remove templates for flake-utils system function
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix23
1 files changed, 12 insertions, 11 deletions
diff --git a/flake.nix b/flake.nix
index 6d63eb8..18b6740 100644
--- a/flake.nix
+++ b/flake.nix
@@ -24,6 +24,17 @@
     flake-utils.lib.eachDefaultSystem (system: let
       pkgs = nixpkgs.legacyPackages."${system}";
     in {
+      devShells.default = pkgs.mkShell {
+        packages = with pkgs; [
+          nil
+          alejandra
+          statix
+          ltex-ls
+          cocogitto
+        ];
+      };
+    })
+    // {
       templates = {
         rust = {
           path = ./rust;
@@ -41,17 +52,7 @@
           welcomeText = "Please customize the text in the flake.nix and LICENSE.spdx files; Look at the TODO marks.\n Also run `git init` and `cog install-hook commit-msg`";
         };
       };
-
-      devShells.default = pkgs.mkShell {
-        packages = with pkgs; [
-          nil
-          alejandra
-          statix
-          ltex-ls
-          cocogitto
-        ];
-      };
-    });
+    };
 }
 # vim: ts=2