about summary refs log tree commit diff stats
path: root/build/c/flake.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-06-11 09:48:15 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-06-11 09:48:15 +0200
commit4f2b735472eb921b5edd91c502e0a47d5e4d0cd2 (patch)
tree35aed5a8f6b650431071e7447565ab6795b790a6 /build/c/flake.nix
parentfix(cog.toml): Update to the newest state (diff)
downloadflake-templates-4f2b735472eb921b5edd91c502e0a47d5e4d0cd2.tar.gz
flake-templates-4f2b735472eb921b5edd91c502e0a47d5e4d0cd2.zip
chore(build): Update
Diffstat (limited to 'build/c/flake.nix')
-rw-r--r--build/c/flake.nix87
1 files changed, 87 insertions, 0 deletions
diff --git a/build/c/flake.nix b/build/c/flake.nix
new file mode 100644
index 0000000..fea015c
--- /dev/null
+++ b/build/c/flake.nix
@@ -0,0 +1,87 @@
+{
+  description = "%INIT_DESCRIPTION";
+
+  inputs = {
+    nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
+
+    treefmt-nix = {
+      url = "github:numtide/treefmt-nix";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+      };
+    };
+
+    flake_version_update = {
+      url = "git+https://codeberg.org/soispha/flake_version_update.git";
+      inputs = {
+        systems.follows = "systems";
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+
+    # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-compat = {
+      url = "github:edolstra/flake-compat";
+      flake = false;
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+  };
+
+  outputs = {
+    self,
+    nixpkgs,
+    flake-utils,
+    treefmt-nix,
+    flake_version_update,
+    ...
+  }:
+    flake-utils.lib.eachDefaultSystem (system: let
+      pkgs = nixpkgs.legacyPackages."${system}";
+
+      nativeBuildInputs = with pkgs; [valgrind pandoc];
+      treefmtEval = import ./treefmt.nix {inherit treefmt-nix pkgs;};
+
+      # This version is set automatically on `cog bump --auto`;
+      version = "v%INIT_APPLICATION_VERSION"; # GUIDING VERSION STRING
+      pname = "%INIT_APPLICATION_NAME";
+
+      build = pkgs.stdenv.mkDerivation {
+        inherit pname version;
+
+        src = ./.;
+        makeFlags = ["PREFIX=${placeholder "out"}" "BIN_VERSION=${version}"];
+        inherit nativeBuildInputs;
+      };
+    in {
+      packages.default = build;
+      checks = {
+        inherit build;
+        formatting = treefmtEval.config.build.check self;
+      };
+      formatter = treefmtEval.config.build.wrapper;
+
+      devShells.default = pkgs.mkShell {
+        packages = with pkgs; [
+          cocogitto
+          flake_version_update.packages."${system}".default
+
+          licensure
+        ];
+        inherit nativeBuildInputs;
+        env = {
+          GCC_COLORS = "error=01;31:warning=01;35:note=01;36:caret=01;32:locus=01:quote=01";
+        };
+      };
+    });
+}
+# vim: ts=2
+