about summary refs log tree commit diff stats
path: root/package/package.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--package/package.nix (renamed from package.nix)22
1 files changed, 13 insertions, 9 deletions
diff --git a/package.nix b/package/package.nix
index 54ee6c1..c0b4718 100644
--- a/package.nix
+++ b/package/package.nix
@@ -8,19 +8,20 @@
 # You should have received a copy of the License along with this program.
 # If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
 {
-  rustPlatform,
-  python3,
-  makeWrapper,
-  sqlite,
-  lib,
   ffmpeg,
-  llvmPackages_latest,
   glibc,
+  lib,
+  llvmPackages_latest,
+  makeWrapper,
   mpv-unwrapped,
+  python3,
+  rustPlatform,
+  sqlite,
+  blake3,
 }: let
   version = "0.1.0";
 
-  src = ./.;
+  src = ./..;
 
   buildInputs = [
     (python3.withPackages (ps: [ps.yt-dlp]))
@@ -52,12 +53,15 @@ in
     };
 
     prePatch = ''
-      echo "$PATH"
       bash ./scripts/mkdb.sh
     '';
 
+    passthru = {
+      inherit blake3;
+    };
+
     cargoLock = {
-      lockFile = ./Cargo.lock;
+      lockFile = ../Cargo.lock;
     };
 
     postBuild = ''