about summary refs log tree commit diff stats
path: root/crates/yt_dlp/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'crates/yt_dlp/Cargo.toml')
-rw-r--r--crates/yt_dlp/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/crates/yt_dlp/Cargo.toml b/crates/yt_dlp/Cargo.toml
new file mode 100644
index 0000000..7af29d7
--- /dev/null
+++ b/crates/yt_dlp/Cargo.toml
@@ -0,0 +1,25 @@
+# yt - A fully featured command line YouTube client
+#
+# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+# This file is part of Yt.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+
+[package]
+name = "yt_dlp"
+description = "A wrapper around the python yt_dlp library"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+log = "0.4.21"
+pyo3 = { version = "0.21.2", features = ["auto-initialize", "gil-refs"] }
+serde = { version = "1.0.203", features = ["derive"] }
+serde_json = "1.0.117"
+url = { version = "2.5.0", features = ["serde"] }
+bytes = {path = "../bytes"}