about summary refs log tree commit diff stats
path: root/yt_dlp/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-23 13:06:00 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-23 13:06:00 +0200
commit52e99b38eae6b4f3cb991342ff9ba9abbab9e42c (patch)
tree9fa6f0582dfb8b6dc7b49bbd6206ab4b533ff900 /yt_dlp/Cargo.toml
parentrefactor(cli): Replace the byte parser with the one from the `bytes` crate (diff)
downloadyt-52e99b38eae6b4f3cb991342ff9ba9abbab9e42c.tar.gz
yt-52e99b38eae6b4f3cb991342ff9ba9abbab9e42c.zip
refactor(yt_dlp): Also move the `crates` subdirectory
Diffstat (limited to 'yt_dlp/Cargo.toml')
-rw-r--r--yt_dlp/Cargo.toml25
1 files changed, 0 insertions, 25 deletions
diff --git a/yt_dlp/Cargo.toml b/yt_dlp/Cargo.toml
deleted file mode 100644
index e5f2efc..0000000
--- a/yt_dlp/Cargo.toml
+++ /dev/null
@@ -1,25 +0,0 @@
-# yt - A fully featured command line YouTube client
-#
-# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of Yt.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-
-[package]
-name = "yt_dlp"
-description = "A wrapper around the python yt_dlp library"
-version = "0.1.0"
-edition = "2021"
-
-# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
-
-[dependencies]
-log = "0.4.21"
-pyo3 = { version = "0.21.2", features = ["auto-initialize", "gil-refs"] }
-serde = { version = "1.0.203", features = ["derive"] }
-serde_json = "1.0.117"
-url = { version = "2.5.0", features = ["serde"] }
-bytes = {path = "./crates/bytes"}