about summary refs log tree commit diff stats
path: root/package.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-21 12:47:29 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-21 12:47:29 +0200
commit61997911557fa8da66598ec54f5f280e1be1dd5d (patch)
tree4baf547d438fe92dc49ef44bba56371b460ee28e /package.nix
parentdocs(NEWS): Add (diff)
downloadyt-61997911557fa8da66598ec54f5f280e1be1dd5d.tar.gz
yt-61997911557fa8da66598ec54f5f280e1be1dd5d.zip
build(flake): Setup up checks (formatter and derivation)
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix79
1 files changed, 28 insertions, 51 deletions
diff --git a/package.nix b/package.nix
index 5035128..d57477b 100644
--- a/package.nix
+++ b/package.nix
@@ -1,54 +1,31 @@
-# yt - A fully featured command line YouTube client
-#
-# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
-# SPDX-License-Identifier: GPL-3.0-or-later
-#
-# This file is part of Yt.
-#
-# You should have received a copy of the License along with this program.
-# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
-
 {
-  lib,
-  makeWrapper,
   rustPlatform,
-  # dependencies
-  ytcc,
-  yt-dlp,
-  mpv,
-}: {
-  yt = import ./yt.nix {
-    inherit
-      lib
-      makeWrapper
-      rustPlatform
-      # dependencies
-      
-      ytcc
-      yt-dlp
-      mpv
-      ;
-  };
-  yts = import ./yts.nix {
-    inherit
-      lib
-      makeWrapper
-      rustPlatform
-      # dependencies
-      
-      ytcc
-      ;
-  };
-  ytc = import ./ytc.nix {
-    inherit
-      lib
-      makeWrapper
-      rustPlatform
-      # dependencies
-      
-      ytcc
-      yt-dlp
-      mpv
-      ;
+  python3,
+  makeWrapper,
+  fetchurl,
+}:
+rustPlatform.buildRustPackage (finalAttrs: {
+  pname = "yt";
+  version = "0.1.0";
+
+  src = fetchurl {
+    url = "https://git.vhack.eu/soispha/clients/yt/${finalAttrs.pname}-${finalAttrs.version}.tar.xz";
+    sha256 = "AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA";
   };
-}
+
+  nativeBuildInputs = [
+    makeWrapper
+    python3.withPackages
+    (ps: [ps.yt-dlp])
+  ];
+
+  postBuild = ''
+    install -m755 ./python_update/raw_update.py -D "$out/bin/raw_update.py"
+    patchShebangs "$out/bin/raw_update.py"
+  '';
+
+  postInstall = ''
+    wrapProgram $out/bin/yt \
+      --prefix PATH : $out/bin/
+  '';
+})