about summary refs log tree commit diff stats
path: root/package.nix
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-21 10:49:23 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-21 11:28:43 +0200
commit1debeb77f7986de1b659dcfdc442de6415e1d9f5 (patch)
tree4df3e7c3f6a2d1ec116e4088c5ace7f143a8b05f /package.nix
downloadyt-1debeb77f7986de1b659dcfdc442de6415e1d9f5.tar.gz
yt-1debeb77f7986de1b659dcfdc442de6415e1d9f5.zip
chore: Initial Commit
This repository was migrated out of my nixos-config.
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/package.nix b/package.nix
new file mode 100644
index 0000000..5035128
--- /dev/null
+++ b/package.nix
@@ -0,0 +1,54 @@
+# yt - A fully featured command line YouTube client
+#
+# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+# This file is part of Yt.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+
+{
+  lib,
+  makeWrapper,
+  rustPlatform,
+  # dependencies
+  ytcc,
+  yt-dlp,
+  mpv,
+}: {
+  yt = import ./yt.nix {
+    inherit
+      lib
+      makeWrapper
+      rustPlatform
+      # dependencies
+      
+      ytcc
+      yt-dlp
+      mpv
+      ;
+  };
+  yts = import ./yts.nix {
+    inherit
+      lib
+      makeWrapper
+      rustPlatform
+      # dependencies
+      
+      ytcc
+      ;
+  };
+  ytc = import ./ytc.nix {
+    inherit
+      lib
+      makeWrapper
+      rustPlatform
+      # dependencies
+      
+      ytcc
+      yt-dlp
+      mpv
+      ;
+  };
+}