about summary refs log tree commit diff stats
path: root/crates/libmpv2/libmpv2-sys/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-23 12:57:19 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-08-23 12:58:02 +0200
commit0ae5018c33cc4bfe27583c9902472b499f4bd269 (patch)
treeafc2fbfcb126215f47afbc32e555d203d4d6d88c /crates/libmpv2/libmpv2-sys/Cargo.toml
parentchore(yt_dlp/progress_hook): Also consider the `total_bytes_estimate` field (diff)
downloadyt-0ae5018c33cc4bfe27583c9902472b499f4bd269.tar.gz
yt-0ae5018c33cc4bfe27583c9902472b499f4bd269.zip
refactor(libmpv2): Move to the `crates` directory
Diffstat (limited to 'crates/libmpv2/libmpv2-sys/Cargo.toml')
-rw-r--r--crates/libmpv2/libmpv2-sys/Cargo.toml21
1 files changed, 21 insertions, 0 deletions
diff --git a/crates/libmpv2/libmpv2-sys/Cargo.toml b/crates/libmpv2/libmpv2-sys/Cargo.toml
new file mode 100644
index 0000000..5fba086
--- /dev/null
+++ b/crates/libmpv2/libmpv2-sys/Cargo.toml
@@ -0,0 +1,21 @@
+# yt - A fully featured command line YouTube client
+#
+# Copyright (C) 2024 Benedikt Peetz <benedikt.peetz@b-peetz.de>
+# SPDX-License-Identifier: GPL-3.0-or-later
+#
+# This file is part of Yt.
+#
+# You should have received a copy of the License along with this program.
+# If not, see <https://www.gnu.org/licenses/gpl-3.0.txt>.
+
+[package]
+name = "libmpv2-sys"
+version = "4.0.0"
+edition = "2021"
+license = "LGPL-2.1"
+build = "build.rs"
+description = "Libmpv bindings generated by bindgen"
+keywords = ["media", "playback", "mpv", "libmpv"]
+
+[build-dependencies]
+bindgen = { version = "0.69.4" }