about summary refs log tree commit diff stats
path: root/crates/bytes/Cargo.toml
diff options
context:
space:
mode:
authorBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-14 14:56:29 +0200
committerBenedikt Peetz <benedikt.peetz@b-peetz.de>2024-10-14 14:56:29 +0200
commit6c9286857ef8b314962b67f4a16a66e8c35531bc (patch)
tree9ced4485ec38b39f82cba258c06321a21c40000a /crates/bytes/Cargo.toml
parentbuild(Cargo.toml): Add further lints (diff)
downloadyt-6c9286857ef8b314962b67f4a16a66e8c35531bc.tar.gz
yt-6c9286857ef8b314962b67f4a16a66e8c35531bc.zip
refactor(treewide): Combine the separate crates in one workspace
Diffstat (limited to 'crates/bytes/Cargo.toml')
-rw-r--r--crates/bytes/Cargo.toml24
1 files changed, 17 insertions, 7 deletions
diff --git a/crates/bytes/Cargo.toml b/crates/bytes/Cargo.toml
index 0dc9833..4439aa8 100644
--- a/crates/bytes/Cargo.toml
+++ b/crates/bytes/Cargo.toml
@@ -10,14 +10,24 @@
 
 [package]
 name = "bytes"
-version = "1.0.0"
-edition = "2021"
-license = "GPL-3.0-or-later"
 description = "Simple byte formatting utilities"
+keywords = []
+categories = []
+version.workspace = true
+edition.workspace = true
+authors.workspace = true
+license.workspace = true
+repository.workspace = true
+rust-version.workspace = true
+publish = false
 
 [dependencies]
-serde = { version = "1.0.210", optional = true }
+serde.workspace = true
 
-[features]
-default = ["serde"]
-serde = ["dep:serde"]
+[dev-dependencies]
+
+[lints]
+workspace = true
+
+[package.metadata.docs.rs]
+all-features = true