summary refs log tree commit diff stats
path: root/zsh.nix
diff options
context:
space:
mode:
Diffstat (limited to 'zsh.nix')
-rw-r--r--zsh.nix28
1 files changed, 19 insertions, 9 deletions
diff --git a/zsh.nix b/zsh.nix
index 547b6ee..ab44a29 100644
--- a/zsh.nix
+++ b/zsh.nix
@@ -1,16 +1,24 @@
 { config, pkgs, ... }:
 
 {
-	programs = {
-		zsh.enable = true;
-		zsh.syntaxHighlighting.enable = true;
-		zsh.autosuggestions.enable = true;
-		zsh.interactiveShellInit = ''
-
+	environment.systemPackages = with pkgs; [ 
+		zsh-powerlevel10k # shell theme
+		oh-my-zsh # configuration framework
+	];
+	programs.zsh.enable = true;
+	programs.zsh.syntaxHighlighting.enable = true;
+	programs.zsh.autosuggestions.enable = true;
+	programs.zsh.interactiveShellInit = ''
+	   	export ZSH=${pkgs.oh-my-zsh}/share/oh-my-zsh/
 		export fpath=("$XDG_DATA_HOME/zsh/site-functions" $fpath)
-		HISTFILE="$XDG_STATE_HOME/zsh/history
+		export HISTFILE="$XDG_STATE_HOME/zsh/history"
+
+		#ZSH_THEME="powerlevel10k/powerlevel10k"
+		# ZSH_CUSTOM=/path/to/new-custom-folder
 
+		plugins=(git zsh-syntax-highlighting zsh-autosuggestions)
 
+# export LANG=en_US.UTF-8
 
 		export EDITOR='nvim'
 		export GOPATH="$XDG_DATA_HOME/go"
@@ -38,9 +46,11 @@
 		alias zenv="vim ~/.config/zsh/.zshenv"
 		alias o="xdg-open"
 		alias wget=wget --hsts-file="$XDG_DATA_HOME/wget-hsts"
+    		
 
+		source $ZSH/oh-my-zsh.sh
+		clear
 	 	'';
 
-		zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
-	};
+ 	programs.zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
 }