summary refs log tree commit diff stats
path: root/sysconf/thinklappi.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sysconf/thinklappi.nix')
-rw-r--r--sysconf/thinklappi.nix66
1 files changed, 0 insertions, 66 deletions
diff --git a/sysconf/thinklappi.nix b/sysconf/thinklappi.nix
deleted file mode 100644
index b6b175c..0000000
--- a/sysconf/thinklappi.nix
+++ /dev/null
@@ -1,66 +0,0 @@
-{
-  config,
-  pkgs,
-  ...
-}: let
-  compiledLayout = pkgs.runCommand "keyboard-layout" {} ''
-    ${pkgs.xorg.xkbcomp}/bin/xkbcomp ${../files/neoqwertz.xkb} $out
-  '';
-in {
-  imports = [
-    ../hardware/basesystem.nix
-    ../env.nix
-    ../nix.nix
-    ../packages.nix
-    ../users.nix
-    ../zsh.nix
-    ../flatpak.nix # Mainly for minecraft
-
-    # Desktop Environment to use
-    ../desktop/gnome.nix
-  ];
-
-  services = {
-    printing.enable = true;
-    xserver = {
-      layout = "de";
-      #xkbVariant = ",neo";
-      xkbOptions = "grp:win_space_toggle";
-      displayManager.sessionCommands = "${pkgs.xorg.xkbcomp}/bin/xkbcomp ${compiledLayout} $DISPLAY";
-    };
-    pipewire = {
-      enable = true;
-      alsa.enable = true;
-      alsa.support32Bit = true;
-      pulse.enable = true;
-      jack.enable = true;
-    };
-  };
-
-  hardware = {
-    bluetooth.enable = true;
-    pulseaudio.enable = false;
-  };
-  security.rtkit.enable = true;
-
-  environment.systemPackages = [pkgs.xorg.xkbcomp];
-
-  i18n.defaultLocale = "en_US.UTF-8";
-
-  networking = {
-    hostName = "thinklappi";
-    networkmanager.enable = true;
-  };
-
-  time.timeZone = "Europe/Berlin";
-
-  console = {
-    font = "Lat2-Terminus16";
-    keyMap = "de";
-    #useXkbConfig = true; # use xkbOptions in tty.
-  };
-
-  programs.ssh.startAgent = true;
-
-  system.stateVersion = "23.05";
-}