summary refs log tree commit diff stats
path: root/sys/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/nix/default.nix')
-rw-r--r--sys/nix/default.nix15
1 files changed, 14 insertions, 1 deletions
diff --git a/sys/nix/default.nix b/sys/nix/default.nix
index 32a6fc5..14abb66 100644
--- a/sys/nix/default.nix
+++ b/sys/nix/default.nix
@@ -1,4 +1,4 @@
-{nixpkgs, ...}: {
+{config, nixpkgs, ...}: {
   nix = {
     registry = {
       nixpkgs.flake = nixpkgs;
@@ -30,4 +30,17 @@
       ];
     };
   };
+    home-manager.users.root.home = {
+    username = "root";
+    homeDirectory = "/root";
+    stateVersion = "23.05";
+    file.".ssh/config" = {
+      text = ''
+      Host server1.vhack.eu
+	            IdentitiesOnly yes
+	            IdentityFIle ${config.age.secrets.nixremote.path}
+	            User nixremote
+      '';
+    };
+  };
 }