summary refs log tree commit diff stats
path: root/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix37
1 files changed, 21 insertions, 16 deletions
diff --git a/packages.nix b/packages.nix
index d7c623f..0b177a0 100644
--- a/packages.nix
+++ b/packages.nix
@@ -3,21 +3,26 @@
 {
 
    environment.systemPackages = with pkgs; [
-     neovim 
-     wget
-     restic
-     thunderbird
-     firefox
-     zsh
-     element-desktop
-     libreoffice
-     keepassxc
-     gnome.gnome-keyring
-     lsd
-     jq
-     glow
-     git
-     signal-desktop
-     openssh
+     neovim # edit nix files ;)
+     wget # download stuff
+     curl # download stuff – reloaded
+     restic # backups
+     thunderbird # emails
+     firefox # my browser
+     zsh # the one and only shell
+     element-desktop # chat
+     libreoffice # convert doc to pdf xD
+     keepassxc # passwords 
+     gnome.gnome-keyring # to tired to migrate to kwallet
+     lsd # ls in good
+     jq # xdg-ninja requieres that
+     glow # markdown rendering
+     git # versioning
+     signal-desktop # the ecosystem is moving :(
+     openssh # ssh
+     jdk17 # openjdk17 to satisfy mr.antoine
+     rustc # rust, obiously
+     cargo # cargo, the best compiler ever"
+     lf # a file manager
    ];
 }