summary refs log tree commit diff stats
path: root/packages.nix
diff options
context:
space:
mode:
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages.nix b/packages.nix
index 1994395..71b250e 100644
--- a/packages.nix
+++ b/packages.nix
@@ -1,6 +1,7 @@
 {
   config,
   pkgs,
+  lib,
   ...
 }: {
   environment.systemPackages = with pkgs; [
@@ -71,7 +72,7 @@
     texlive.combined.scheme-full # LaTeX
     gparted # partitioning :(
     musescore # notesetting program
-
+    geogebra # math program
     # Compiler
     gcc
     execline
@@ -80,4 +81,8 @@
     texlab # latex language server
     html-tidy # html formatter
   ];
+  nixpkgs.config.allowUnfreePredicate = pkg:
+    builtins.elem (lib.getName pkg) [
+      "geogebra"
+    ];
 }