summary refs log tree commit diff stats
path: root/hosts/thinklappi/thinklappi.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--hosts/thinklappi/thinklappi.nix (renamed from sysconf/thinklappi.nix)22
1 files changed, 13 insertions, 9 deletions
diff --git a/sysconf/thinklappi.nix b/hosts/thinklappi/thinklappi.nix
index b6b175c..5a3f0f6 100644
--- a/sysconf/thinklappi.nix
+++ b/hosts/thinklappi/thinklappi.nix
@@ -8,16 +8,16 @@
   '';
 in {
   imports = [
-    ../hardware/basesystem.nix
-    ../env.nix
-    ../nix.nix
-    ../packages.nix
-    ../users.nix
-    ../zsh.nix
-    ../flatpak.nix # Mainly for minecraft
+    ./basesystem.nix
+    ../../env.nix
+    ../../nix.nix
+    ../../packages.nix
+    ../../users.nix
+    ../../zsh.nix
+    ../../flatpak.nix # Mainly for minecraft
 
     # Desktop Environment to use
-    ../desktop/gnome.nix
+    ../../desktop/gnome.nix
   ];
 
   services = {
@@ -49,7 +49,11 @@ in {
 
   networking = {
     hostName = "thinklappi";
-    networkmanager.enable = true;
+    nameservers = ["2620:fe::fe" "2620:fe::9" "9.9.9.9" "149.112.112.112"];
+    networkmanager = {
+      enable = true;
+      dns = "none";
+    };
   };
 
   time.timeZone = "Europe/Berlin";