summary refs log tree commit diff stats
path: root/hosts/thinklappi-bootstrap/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hosts/thinklappi-bootstrap/default.nix')
-rw-r--r--hosts/thinklappi-bootstrap/default.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/hosts/thinklappi-bootstrap/default.nix b/hosts/thinklappi-bootstrap/default.nix
new file mode 100644
index 0000000..10ed8ef
--- /dev/null
+++ b/hosts/thinklappi-bootstrap/default.nix
@@ -0,0 +1,46 @@
+{
+  config,
+  pkgs,
+  ...
+}: {
+  imports = [
+    ./basesystem.nix
+    ../../sys/users
+  ];
+
+  hardware = {
+    opengl.enable = true;
+    bluetooth.enable = true;
+    pulseaudio.enable = false;
+  };
+
+  virtualisation.waydroid.enable = true; # Android emulation
+
+  security = {
+    rtkit.enable = true;
+    pam.services.swaylock = {};
+  };
+
+  environment.systemPackages = [
+    pkgs.xorg.xkbcomp
+    pkgs.neovim
+    pkgs.git
+  ];
+
+  i18n.defaultLocale = "en_US.UTF-8";
+
+  networking = {
+    hostName = "thinklappi";
+    #nameservers = ["2620:fe::fe" "2620:fe::9" "9.9.9.9" "149.112.112.112"];
+    networkmanager = {
+      enable = true;
+      #dns = "none";
+    };
+  };
+
+  time.timeZone = "Europe/Berlin";
+
+  programs.ssh.startAgent = true;
+
+  system.stateVersion = "23.05";
+}