summary refs log tree commit diff stats
path: root/hm/swayidle/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/swayidle/default.nix')
-rw-r--r--hm/swayidle/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/hm/swayidle/default.nix b/hm/swayidle/default.nix
new file mode 100644
index 0000000..32befa2
--- /dev/null
+++ b/hm/swayidle/default.nix
@@ -0,0 +1,28 @@
+{pkgs, ...}: {
+  services.swayidle = {
+    enable = true;
+    events = [
+      # TODO: Find a way to close keepassxc-database on lock
+      #{
+      #  event = "lock";
+      #  command = "";
+      #}
+      {
+        event = "before-sleep";
+        command = "${pkgs.swaylock}/bin/swaylock -f";
+      }
+    ];
+    timeouts = [
+      {
+        timeout = 160;
+        command = "${pkgs.swaylock}/bin/swaylock -f";
+      }
+      #{
+      #  timeout = 40;
+      #  command = "${pkgs.hyprland}/bin/hyprctl dispatch dpms off";
+      #  resumeCommand = "${pkgs.hyprland}/bin/hyprctl dispatch dpms on";
+      #}
+    ];
+    systemdTarget = "hyprland-session.target";
+  };
+}