summary refs log tree commit diff stats
path: root/hm/neovim/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'hm/neovim/default.nix')
-rw-r--r--hm/neovim/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/hm/neovim/default.nix b/hm/neovim/default.nix
new file mode 100644
index 0000000..947f0bf
--- /dev/null
+++ b/hm/neovim/default.nix
@@ -0,0 +1,16 @@
+{pkgs, ...}: {
+  programs.neovim = {
+    enable = true;
+    defaultEditor = true;
+    viAlias = true;
+    vimAlias = true;
+    vimdiffAlias = true;
+    #extraLuaConfig = builtins.readFile ./lua/options.lua;
+    #    extraConfig = ''
+    #      inoremap jj <esc>
+    #    '';
+    #    plugins = with pkgs.vimPlugins; [
+    #      neo-tree-nvim
+    #    ];
+  };
+}