summary refs log tree commit diff stats
path: root/flake/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake/default.nix')
-rw-r--r--flake/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/flake/default.nix b/flake/default.nix
index 443999e..a0e3d57 100644
--- a/flake/default.nix
+++ b/flake/default.nix
@@ -50,5 +50,18 @@
   };
   flake = {
     nixosConfigurations = import ./nixosConfigurations inputs;
+      homeConfigurations."silas" = inputs.home-manager.lib.homeManagerConfiguration {
+    		pkgs = import inputs.nixpkgs {
+    		  system = "x86_64-linux";
+    		  overlays = [inputs.nixvim.overlays.default];
+    		};
+        # Specify your home configuration modules here, for example,
+        # the path to your home.nix.
+        modules = [ ../hm/silas ];
+
+        # Optionally use extraSpecialArgs
+        # to pass through arguments to home.nix
+				extraSpecialArgs = inputs;
+    };
   };
 }