summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 5 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
index e9636b3..5236972 100644
--- a/flake.nix
+++ b/flake.nix
@@ -151,6 +151,7 @@
       overlays = [nixvim.overlays.default];
     };
     sysLib = shell_library.lib.${system};
+    nixVimConfig = import ./users/sils/nixvim/config.nix;
     defaultModules = [
       impermanence.nixosModules.impermanence
       lanzaboote.nixosModules.lanzaboote
@@ -200,5 +201,9 @@
       };
 
       formatter = pkgs.alejandra;
+
+      packages = {
+        nvim = nixvim.legacyPackages."${system}".makeNixvim nixVimConfig;
+      };
     });
 }