summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix26
1 files changed, 18 insertions, 8 deletions
diff --git a/flake.nix b/flake.nix
index 0c27b6a..ad175f6 100644
--- a/flake.nix
+++ b/flake.nix
@@ -157,14 +157,24 @@
       }
     ];
   in {
-    nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
-      inherit system;
-      specialArgs = attrs;
-      modules =
-        [
-          ./hosts/thinklappi
-        ]
-        ++ defaultModules;
+    nixosConfigurations = {
+      thinklappi = nixpkgs.lib.nixosSystem {
+        inherit system;
+        specialArgs = attrs;
+        modules =
+          [
+            ./hosts/thinklappi
+          ]
+          ++ defaultModules;
+      };
+      thinklappi-bootstrap = nixpkgs.lib.nixosSystem {
+        inherit system;
+        specialArgs = attrs;
+        modules = [
+          ./hosts/thinklappi-bootstrap
+          lanzaboote.nixosModules.lanzaboote
+        ];
+      };
     };
     devShells."${system}" = {
       default = pkgs.mkShell {