summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix17
1 files changed, 14 insertions, 3 deletions
diff --git a/flake.nix b/flake.nix
index 3b08173..7e892be 100644
--- a/flake.nix
+++ b/flake.nix
@@ -12,11 +12,22 @@
     nixpkgs,
     home-manager,
     ...
-  } @ attrs: {
+  } @ attrs: let
+    system = "86_64-linux";
+  in {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
-      system = "x86_64-linux";
+      inherit system;
       specialArgs = attrs;
-      modules = [./hosts/thinklappi];
+      modules = [
+        ./hosts/thinklappi
+        home-manager.nixosModules.home-manager
+        {
+          home-manager.useGlobalPkgs = true;
+          home-manager.useUserPackages = true;
+          home-manager.users.sils = import ./users/sils;
+          home-manager.extraSpecialArgs = {inherit nixpkgs system;};
+        }
+      ];
     };
   };
 }