summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index aaf2992..184fd09 100644
--- a/flake.nix
+++ b/flake.nix
@@ -2,10 +2,10 @@
   description = "My Nixos system configuration";
   # inputs {{{
   inputs = {
-    nixpkgs.url = "github:NixOs/nixpkgs/nixos-23.05";
-    unstable.url = "github:NixOs/nixpkgs/nixos-unstable";
+    stable.url = "github:NixOs/nixpkgs/nixos-23.05";
+    nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
     home-manager = {
-      url = "github:nix-community/home-manager/release-23.05";
+      url = "github:nix-community/home-manager"; #/release-23.05";
       inputs.nixpkgs.follows = "nixpkgs";
     };
 
@@ -114,17 +114,19 @@
     ...
   } @ attrs: let
     system = "x86_64-linux";
-    pkgs = nixpkgs.legacyPackages."${system}";
+    pkgs = import nixpkgs {
+      inherit system;
+     # overlays = [ nixneovim.overlays.default ];
+    };#nixpkgs.legacyPackages."${system}";
 
     sysLib = shell_library.lib.${system};
   in {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       inherit system;
       specialArgs = attrs;
-      nixpkgs.overlays = [ nixneovim.overlays.default ];
       modules = [
         lanzaboote.nixosModules.lanzaboote
-        nixneovim.nixosModules.default
+        #nixneovim.nixosModules.default
         ./hosts/thinklappi
         home-manager.nixosModules.home-manager
         {