summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix56
1 files changed, 55 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index b1a0696..d416b72 100644
--- a/flake.nix
+++ b/flake.nix
@@ -6,15 +6,69 @@
       url = "github:nix-community/home-manager/master";
       inputs.nixpkgs.follows = "nixpkgs";
     };
+
+    # inputs for following
+    systems = {
+      url = "github:nix-systems/x86_64-linux"; # only evaluate for this system
+    };
+    flake-compat = {
+      url = "github:edolstra/flake-compat";
+      flake = false;
+    };
+    crane = {
+      url = "github:ipetkov/crane";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-compat.follows = "flake-compat";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+      };
+    };
+    flake-utils = {
+      url = "github:numtide/flake-utils";
+      inputs = {
+        systems.follows = "systems";
+      };
+    };
+    rust-overlay = {
+      url = "github:oxalica/rust-overlay";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+      };
+    };
+
+    shell_library = {
+      url = "git+https://codeberg.org/soispha/shell_library.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        flake-utils.follows = "flake-utils";
+        systems.follows = "systems";
+      };
+    };
+    river_init_lesser = {
+      url = "git+https://codeberg.org/soispha/river_keymap_init.git";
+      inputs = {
+        nixpkgs.follows = "nixpkgs";
+        crane.follows = "crane";
+        flake-utils.follows = "flake-utils";
+        rust-overlay.follows = "rust-overlay";
+        flake-compat.follows = "flake-compat";
+      };
+    };
   };
   outputs = {
     self,
     nixpkgs,
     home-manager,
+    shell_library,
+    river_init_lesser,
     ...
   } @ attrs: let
     system = "x86_64-linux";
     pkgs = nixpkgs.legacyPackages."${system}";
+
+    sysLib = shell_library.lib.${system};
   in {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       inherit system;
@@ -26,7 +80,7 @@
           home-manager.useGlobalPkgs = true;
           home-manager.useUserPackages = true;
           home-manager.users.sils = import ./users/sils;
-          home-manager.extraSpecialArgs = {inherit nixpkgs system;};
+          home-manager.extraSpecialArgs = {inherit nixpkgs system sysLib river_init_lesser;};
         }
       ];
     };