summary refs log tree commit diff stats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--flake.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 37a7906..a41d092 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,10 +1,17 @@
 {
+  description = "My Nixo system configuration";
+  inputs = {
+    nixpkgs.url = "github:NixOs/nixpkgs/nixos-unstable";
+    home-manager.url = "github:nix-community/home-manager/master";
+  };
   outputs = {
     self,
     nixpkgs,
-  }: {
+    ...
+  } @ attrs : {
     nixosConfigurations.thinklappi = nixpkgs.lib.nixosSystem {
       system = "x86_64-linux";
+      specialArgs = attrs;
       modules = [./sysconf/thinklappi.nix];
     };
   };