summary refs log tree commit diff stats
path: root/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--configuration.nix108
1 files changed, 55 insertions, 53 deletions
diff --git a/configuration.nix b/configuration.nix
index df0dd20..819cec8 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,64 +1,66 @@
-{ config, pkgs, ... }:
-	let
-	  compiledLayout = pkgs.runCommand "keyboard-layout" {} ''
-	    ${pkgs.xorg.xkbcomp}/bin/xkbcomp ${./files/neoqwertz.xkb} $out
-	  '';
-	in
 {
-	imports = [ 
-		./hardware/basesystem.nix
-		./env.nix
-		./nix.nix
-		./packages.nix
-		./users.nix
-		./zsh.nix
-		./flatpak.nix # Mainly for minecraft
+  config,
+  pkgs,
+  ...
+}: let
+  compiledLayout = pkgs.runCommand "keyboard-layout" {} ''
+    ${pkgs.xorg.xkbcomp}/bin/xkbcomp ${./files/neoqwertz.xkb} $out
+  '';
+in {
+  imports = [
+    ./hardware/basesystem.nix
+    ./env.nix
+    ./nix.nix
+    ./packages.nix
+    ./users.nix
+    ./zsh.nix
+    ./flatpak.nix # Mainly for minecraft
 
-		# Desktop Environment to use
-		./desktop/plasma.nix
-	];
-	
-	services = {
-		printing.enable = true;
-		xserver = {
-  			layout = "de";
-  			#xkbVariant = ",neo";
-  			xkbOptions = "grp:win_space_toggle";
-			displayManager.sessionCommands = "${pkgs.xorg.xkbcomp}/bin/xkbcomp ${compiledLayout} $DISPLAY";
-		};
-		pipewire = {
-			enable = true;
-			alsa.enable = true;
-			alsa.support32Bit = true;
-			pulse.enable = true;
-			jack.enable = true;
-		};
-	};
+    # Desktop Environment to use
+    ./desktop/plasma.nix
+  ];
 
-	hardware = {
-		bluetooth.enable = true;
-		pulseaudio.enable = false;
-	};
-	security.rtkit.enable = true;
+  services = {
+    printing.enable = true;
+    xserver = {
+      layout = "de";
+      #xkbVariant = ",neo";
+      xkbOptions = "grp:win_space_toggle";
+      displayManager.sessionCommands = "${pkgs.xorg.xkbcomp}/bin/xkbcomp ${compiledLayout} $DISPLAY";
+    };
+    pipewire = {
+      enable = true;
+      alsa.enable = true;
+      alsa.support32Bit = true;
+      pulse.enable = true;
+      jack.enable = true;
+    };
+  };
 
-	environment.systemPackages = [ pkgs.xorg.xkbcomp ];
+  hardware = {
+    bluetooth.enable = true;
+    pulseaudio.enable = false;
+  };
+  security.rtkit.enable = true;
 
-	i18n.defaultLocale = "en_US.UTF-8";
+  environment.systemPackages = [pkgs.xorg.xkbcomp];
 
-	networking = {
-		hostName = "thinklappi";
-		networkmanager.enable = true;
-	};
+  i18n.defaultLocale = "en_US.UTF-8";
 
-   	time.timeZone = "Europe/Berlin";
+  networking = {
+    hostName = "thinklappi";
+    networkmanager.enable = true;
+  };
 
-   	console = {
-     		font = "Lat2-Terminus16";
-     		keyMap = "de";
-     		#useXkbConfig = true; # use xkbOptions in tty.
-   	};
+  time.timeZone = "Europe/Berlin";
 
-	programs.ssh.startAgent = true;
+  console = {
+    font = "Lat2-Terminus16";
+    keyMap = "de";
+    #useXkbConfig = true; # use xkbOptions in tty.
+  };
 
-	system.stateVersion = "23.05";
+  programs.ssh.startAgent = true;
+
+  system.stateVersion = "23.05";
 }