summary refs log tree commit diff stats
path: root/common/nix/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'common/nix/default.nix')
-rw-r--r--common/nix/default.nix13
1 files changed, 13 insertions, 0 deletions
diff --git a/common/nix/default.nix b/common/nix/default.nix
new file mode 100644
index 0000000..30f5b38
--- /dev/null
+++ b/common/nix/default.nix
@@ -0,0 +1,13 @@
+{...}: {
+  nix = {
+    gc = {
+      automatic = true;
+      dates = "daily";
+      options = "--delete-older-than 3";
+    };
+    settings = {
+      auto-optimise-store = true;
+      experimental-features = ["nix-command" "flakes"];
+    };
+  };
+}