summary refs log tree commit diff stats
path: root/zsh.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2022-12-08 19:59:20 +0100
committersils <sils@sils.li>2022-12-08 19:59:20 +0100
commit0c0284e69d6ffdc3c915fe6d7a32de47a084661e (patch)
tree29b887dab0f23933400e0fe9fc0d92aeb8d385e4 /zsh.nix
parent7zip (diff)
downloadnix-config-0c0284e69d6ffdc3c915fe6d7a32de47a084661e.tar.gz
nix-config-0c0284e69d6ffdc3c915fe6d7a32de47a084661e.zip
Added zsh configuration
Diffstat (limited to 'zsh.nix')
-rw-r--r--zsh.nix56
1 files changed, 56 insertions, 0 deletions
diff --git a/zsh.nix b/zsh.nix
new file mode 100644
index 0000000..ab44a29
--- /dev/null
+++ b/zsh.nix
@@ -0,0 +1,56 @@
+{ config, pkgs, ... }:
+
+{
+	environment.systemPackages = with pkgs; [ 
+		zsh-powerlevel10k # shell theme
+		oh-my-zsh # configuration framework
+	];
+	programs.zsh.enable = true;
+	programs.zsh.syntaxHighlighting.enable = true;
+	programs.zsh.autosuggestions.enable = true;
+	programs.zsh.interactiveShellInit = ''
+	   	export ZSH=${pkgs.oh-my-zsh}/share/oh-my-zsh/
+		export fpath=("$XDG_DATA_HOME/zsh/site-functions" $fpath)
+		export HISTFILE="$XDG_STATE_HOME/zsh/history"
+
+		#ZSH_THEME="powerlevel10k/powerlevel10k"
+		# ZSH_CUSTOM=/path/to/new-custom-folder
+
+		plugins=(git zsh-syntax-highlighting zsh-autosuggestions)
+
+# export LANG=en_US.UTF-8
+
+		export EDITOR='nvim'
+		export GOPATH="$XDG_DATA_HOME/go"
+		alias vim="nvim"
+		alias ls='lsd'
+		alias l='ls -l'
+		alias la='ls -a'
+		alias lla='ls -la'
+		alias lt='ls --tree'
+		alias rebackup='restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd backup'
+		alias repreconf='restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd'
+		alias b-del="sudo btrfs subv delet /srv/snapshots/home"
+		alias b-shot="sudo btrfs subvolume snapshot -r /home /srv/snapshots/home"
+		alias ba='[ -d /srv/snapshots/home ] && sudo btrfs subvolume delete /srv/snapshots/home; [ -d /srv/snapshots/root ] && sudo btrfs subvolume delete /srv/snapshots/root; sudo btrfs subvolume snapshot -r /home /srv/snapshots/home; sudo btrfs subvolume snapshot -r / /srv/snapshots/root; sudo restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd backup /srv/snapshots/home; sudo restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd backup /srv/snapshots/root;'
+		alias r-clean="sudo restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd forget \
+                        	--keep-weekly  7  \
+                        	--keep-daily   7  \
+                        	--keep-monthly 6  \
+                        	--keep-yearly  10 \
+                        	--keep-hourly  5  \
+                        	--keep-tag prs"
+		alias r-prune="sudo restic -r /mnt/storage/backups --password-file ~/srv/restic_pswd prune"
+		alias r-check="sudo restic -r /mnt/storage/backups --cache-dir /root/.cache --password-file ~/srv/.restic_pswd check"
+		alias zconf="vim ~/.config/zsh/.zshrc"
+		alias zenv="vim ~/.config/zsh/.zshenv"
+		alias o="xdg-open"
+		alias wget=wget --hsts-file="$XDG_DATA_HOME/wget-hsts"
+    		
+
+		source $ZSH/oh-my-zsh.sh
+		clear
+	 	'';
+
+ 	programs.zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+}