summary refs log tree commit diff stats
path: root/zsh.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2022-12-10 21:36:02 +0100
committersils <sils@sils.li>2022-12-10 21:36:02 +0100
commit88b5c79e77befb3175de8cae0d4c60af22beb72d (patch)
treeb5312da6f037664ff067aad2c22118b1f23abbaa /zsh.nix
parentenable bluetooth (diff)
downloadnix-config-88b5c79e77befb3175de8cae0d4c60af22beb72d.tar.gz
nix-config-88b5c79e77befb3175de8cae0d4c60af22beb72d.zip
improve prompt
Diffstat (limited to 'zsh.nix')
-rw-r--r--zsh.nix28
1 files changed, 10 insertions, 18 deletions
diff --git a/zsh.nix b/zsh.nix
index ab44a29..e8a05d4 100644
--- a/zsh.nix
+++ b/zsh.nix
@@ -1,24 +1,16 @@
 { config, pkgs, ... }:
 
 {
-	environment.systemPackages = with pkgs; [ 
-		zsh-powerlevel10k # shell theme
-		oh-my-zsh # configuration framework
-	];
-	programs.zsh.enable = true;
-	programs.zsh.syntaxHighlighting.enable = true;
-	programs.zsh.autosuggestions.enable = true;
-	programs.zsh.interactiveShellInit = ''
+	programs = {
+	     zsh.enable = true;
+	     zsh.syntaxHighlighting.enable = true;
+	     zsh.autosuggestions.enable = true;
+	     zsh.interactiveShellInit = ''
 	   	export ZSH=${pkgs.oh-my-zsh}/share/oh-my-zsh/
 		export fpath=("$XDG_DATA_HOME/zsh/site-functions" $fpath)
-		export HISTFILE="$XDG_STATE_HOME/zsh/history"
+		HISTFILE="$XDG_STATE_HOME/zsh/history"
 
-		#ZSH_THEME="powerlevel10k/powerlevel10k"
-		# ZSH_CUSTOM=/path/to/new-custom-folder
-
-		plugins=(git zsh-syntax-highlighting zsh-autosuggestions)
-
-# export LANG=en_US.UTF-8
+		plugins=(git)
 
 		export EDITOR='nvim'
 		export GOPATH="$XDG_DATA_HOME/go"
@@ -49,8 +41,8 @@
     		
 
 		source $ZSH/oh-my-zsh.sh
-		clear
 	 	'';
-
- 	programs.zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+	
+	     zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+	};
 }