summary refs log tree commit diff stats
path: root/zsh.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2022-12-11 14:24:09 +0100
committersils <sils@sils.li>2022-12-11 14:24:09 +0100
commit445af791c847ce4bac77b36bf6aceda2c58eb60b (patch)
tree483e912cf18a5b7b864a0a97de8368bd4834f653 /zsh.nix
parentfix editor (diff)
downloadnix-config-445af791c847ce4bac77b36bf6aceda2c58eb60b.tar.gz
nix-config-445af791c847ce4bac77b36bf6aceda2c58eb60b.zip
restructure zsh.nix
Diffstat (limited to 'zsh.nix')
-rw-r--r--zsh.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/zsh.nix b/zsh.nix
index e8a05d4..7d24aac 100644
--- a/zsh.nix
+++ b/zsh.nix
@@ -1,11 +1,11 @@
 { config, pkgs, ... }:
 
 {
-	programs = {
-	     zsh.enable = true;
-	     zsh.syntaxHighlighting.enable = true;
-	     zsh.autosuggestions.enable = true;
-	     zsh.interactiveShellInit = ''
+	programs.zsh = {
+	     enable = true;
+	     syntaxHighlighting.enable = true;
+	     autosuggestions.enable = true;
+	     interactiveShellInit = ''
 	   	export ZSH=${pkgs.oh-my-zsh}/share/oh-my-zsh/
 		export fpath=("$XDG_DATA_HOME/zsh/site-functions" $fpath)
 		HISTFILE="$XDG_STATE_HOME/zsh/history"
@@ -43,6 +43,6 @@
 		source $ZSH/oh-my-zsh.sh
 	 	'';
 	
-	     zsh.promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
+	     promptInit = "source ${pkgs.zsh-powerlevel10k}/share/zsh-powerlevel10k/powerlevel10k.zsh-theme";
 	};
 }