summary refs log tree commit diff stats
path: root/users.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2022-12-04 18:20:29 +0100
committersils <sils@sils.li>2022-12-04 18:34:14 +0100
commit6faed86ea6e5518ff186ca1ec4104d5eefe21091 (patch)
treedba56dac7845b5ce50bf9837f4080d0ddfdea20f /users.nix
parentInitial nix-config (diff)
downloadnix-config-6faed86ea6e5518ff186ca1ec4104d5eefe21091.tar.gz
nix-config-6faed86ea6e5518ff186ca1ec4104d5eefe21091.zip
Modularize config
Diffstat (limited to 'users.nix')
-rw-r--r--users.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/users.nix b/users.nix
new file mode 100644
index 0000000..c99bbd4
--- /dev/null
+++ b/users.nix
@@ -0,0 +1,11 @@
+{ config, pkgs, ... }:
+
+{
+   users.users.sils = {
+     isNormalUser = true;
+     home = "/home/sils";
+     shell = pkgs.zsh;
+     extraGroups = [ "wheel" "networkmanager"]; 
+   };
+
+}