summary refs log tree commit diff stats
path: root/users.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-01-08 19:30:04 +0100
committersils <sils@sils.li>2023-01-08 19:30:04 +0100
commite70b7da28c7590a594ab209e959a5bc135e61811 (patch)
tree26eb976e5b08f0e27c0efb785c3647e49d177d82 /users.nix
parentswitch away from temp-root (diff)
downloadnix-config-e70b7da28c7590a594ab209e959a5bc135e61811.tar.gz
nix-config-e70b7da28c7590a594ab209e959a5bc135e61811.zip
introduce alejandra
Diffstat (limited to '')
-rw-r--r--users.nix47
1 files changed, 24 insertions, 23 deletions
diff --git a/users.nix b/users.nix
index f63d188..cff3e1d 100644
--- a/users.nix
+++ b/users.nix
@@ -1,25 +1,26 @@
-{ config, pkgs, ... }:
-
 {
-   users = {
-   	mutableUsers = false;
-   	users.sils = {
-     		isNormalUser = true;
-     		home = "/home/sils";
-     		shell = pkgs.zsh;
-     		initialHashedPassword = "$y$j9T$r4578Hy9jZHmUH9uSr9OI.$SuR2anRq7EJ1gUJ6vi9qYmZrhLP.o3O5643IG6r5Ap/";
-     		extraGroups = [ "wheel" "networkmanager"]; 
-   	};
-	users.cnnr = {
-		isNormalUser = true;
-		home = "/home/cnnr";
-		shell = pkgs.zsh;
-		initialHashedPassword = "$y$j9T$NFz0d2coUOvl.hL3YRwEY0$8btvXUoWGWwo11ksdt8eIFUljCkpUe0YliEy7l0odU1";
-	};
-   };
-   services.xserver.displayManager.autoLogin = {
-   	enable = true;
-   	user = "sils";
-   };
-
+  config,
+  pkgs,
+  ...
+}: {
+  users = {
+    mutableUsers = false;
+    users.sils = {
+      isNormalUser = true;
+      home = "/home/sils";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$j9T$r4578Hy9jZHmUH9uSr9OI.$SuR2anRq7EJ1gUJ6vi9qYmZrhLP.o3O5643IG6r5Ap/";
+      extraGroups = ["wheel" "networkmanager"];
+    };
+    users.cnnr = {
+      isNormalUser = true;
+      home = "/home/cnnr";
+      shell = pkgs.zsh;
+      initialHashedPassword = "$y$j9T$NFz0d2coUOvl.hL3YRwEY0$8btvXUoWGWwo11ksdt8eIFUljCkpUe0YliEy7l0odU1";
+    };
+  };
+  services.xserver.displayManager.autoLogin = {
+    enable = true;
+    user = "sils";
+  };
 }