summary refs log tree commit diff stats
path: root/packages.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-01-08 19:30:04 +0100
committersils <sils@sils.li>2023-01-08 19:30:04 +0100
commite70b7da28c7590a594ab209e959a5bc135e61811 (patch)
tree26eb976e5b08f0e27c0efb785c3647e49d177d82 /packages.nix
parentswitch away from temp-root (diff)
downloadnix-config-e70b7da28c7590a594ab209e959a5bc135e61811.tar.gz
nix-config-e70b7da28c7590a594ab209e959a5bc135e61811.zip
introduce alejandra
Diffstat (limited to 'packages.nix')
-rw-r--r--packages.nix113
1 files changed, 57 insertions, 56 deletions
diff --git a/packages.nix b/packages.nix
index 99d7373..6c80d9e 100644
--- a/packages.nix
+++ b/packages.nix
@@ -1,61 +1,62 @@
-{ config, pkgs, ... }:
-
 {
+  config,
+  pkgs,
+  ...
+}: {
+  environment.systemPackages = with pkgs; [
+    neovim # edit nix files ;)
+    neofetch # a must-have
+    wget # download stuff
+    curl # download stuff – reloaded
+    restic # backups
+    thunderbird # emails
+    firefox # my browser
+    librewolf # privacy friendly firefox
+    ungoogled-chromium # the only chromium-based browser I'd ever use.
+    zsh # the one and only shell
+    element-desktop # chat
+    libreoffice # convert doc to pdf xD
+    keepassxc # passwords
+    gnome.gnome-keyring # to tired to migrate to kwallet
+    gnome.simple-scan # scanning, obiously
+    lsd # ls in good
+    jq # xdg-ninja requieres that
+    glow # markdown rendering
+    xdg-ninja # home cleaning
+    git # versioning
+    signal-desktop # the ecosystem is moving :(
+    mumble # voice chat
+    alejandra # nix code formatter
 
-   environment.systemPackages = with pkgs; [
-     neovim # edit nix files ;)
-     neofetch # a must-have
-     wget # download stuff
-     curl # download stuff – reloaded
-     restic # backups
-     thunderbird # emails
-     firefox # my browser
-     librewolf # privacy friendly firefox
-     ungoogled-chromium # the only chromium-based browser I'd ever use.
-     zsh # the one and only shell
-     element-desktop # chat
-     libreoffice # convert doc to pdf xD
-     keepassxc # passwords 
-     gnome.gnome-keyring # to tired to migrate to kwallet
-     gnome.simple-scan # scanning, obiously
-     lsd # ls in good
-     jq # xdg-ninja requieres that
-     glow # markdown rendering
-     xdg-ninja # home cleaning
-     git # versioning
-     signal-desktop # the ecosystem is moving :(
-     mumble # voice chat
-
-     # SSH Stuff
-     openssh # ssh
-     mosh # ssh in great
+    # SSH Stuff
+    openssh # ssh
+    mosh # ssh in great
 
-     jdk17 # openjdk17 to satisfy mr.antoine
-     rustc # rust, obiously
-     cargo # cargo, the best compiler ever"
-     lf # a file manager
-     gnupg # encryprtion and so on
-     tor-browser-bundle-bin # tor-browser
-     tdesktop # another messenger (telegram)
-     libsForQt5.kdeconnect-kde # communicate with my phone
-     imagemagick # convertion and so on
-     #nerdfonts # nice fonts, u know
-     alacritty # terminal
-     konsole # terminal
- 
+    jdk17 # openjdk17 to satisfy mr.antoine
+    rustc # rust, obiously
+    cargo # cargo, the best compiler ever"
+    lf # a file manager
+    gnupg # encryprtion and so on
+    tor-browser-bundle-bin # tor-browser
+    tdesktop # another messenger (telegram)
+    libsForQt5.kdeconnect-kde # communicate with my phone
+    imagemagick # convertion and so on
+    #nerdfonts # nice fonts, u know
+    alacritty # terminal
+    konsole # terminal
 
-     zsh-you-should-use # reminder for aliasses
-     jetbrains.idea-community # Java-IDE
-     python39 # python programming language
-     _7zz # 7zip archive utility
-     sayonara # audioplayer
-     vlc # audio, again
-     nmap # network scanning
-     tree # tree view of directories
-     youtube-dl # download videos
-     mpv # play videos
-     texlive.combined.scheme-full # LaTeX
-     gparted # partitioning :(
-     musescore # notesetting program
-   ];
+    zsh-you-should-use # reminder for aliasses
+    jetbrains.idea-community # Java-IDE
+    python39 # python programming language
+    _7zz # 7zip archive utility
+    sayonara # audioplayer
+    vlc # audio, again
+    nmap # network scanning
+    tree # tree view of directories
+    youtube-dl # download videos
+    mpv # play videos
+    texlive.combined.scheme-full # LaTeX
+    gparted # partitioning :(
+    musescore # notesetting program
+  ];
 }