summary refs log tree commit diff stats
path: root/packages.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-02-22 19:02:16 +0100
committersils <sils@sils.li>2023-02-22 19:42:16 +0100
commit3944a9730690f6ebd4d4eaf520dcd94291a880c3 (patch)
tree166719653688a4350ca01ed9fa6fb062263653e2 /packages.nix
parentStructure: Switch back to gnome. (diff)
downloadnix-config-3944a9730690f6ebd4d4eaf520dcd94291a880c3.tar.gz
nix-config-3944a9730690f6ebd4d4eaf520dcd94291a880c3.zip
Packages: Add geogebra
Diffstat (limited to '')
-rw-r--r--packages.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/packages.nix b/packages.nix
index 1994395..71b250e 100644
--- a/packages.nix
+++ b/packages.nix
@@ -1,6 +1,7 @@
 {
   config,
   pkgs,
+  lib,
   ...
 }: {
   environment.systemPackages = with pkgs; [
@@ -71,7 +72,7 @@
     texlive.combined.scheme-full # LaTeX
     gparted # partitioning :(
     musescore # notesetting program
-
+    geogebra # math program
     # Compiler
     gcc
     execline
@@ -80,4 +81,8 @@
     texlab # latex language server
     html-tidy # html formatter
   ];
+  nixpkgs.config.allowUnfreePredicate = pkg:
+    builtins.elem (lib.getName pkg) [
+      "geogebra"
+    ];
 }