summary refs log tree commit diff stats
path: root/hardware/basesystem.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2023-03-18 10:12:58 +0100
committersils <sils@sils.li>2023-03-18 10:18:37 +0100
commit495c661f5081c023c242e96cf99259181408e99a (patch)
tree1a1c105e4046de38ef4f812345eee33f3eb3f6e0 /hardware/basesystem.nix
parentPackages: Add zip-utils (diff)
downloadnix-config-495c661f5081c023c242e96cf99259181408e99a.tar.gz
nix-config-495c661f5081c023c242e96cf99259181408e99a.zip
Feat: Restructure and add nameservers.
Diffstat (limited to 'hardware/basesystem.nix')
-rw-r--r--hardware/basesystem.nix85
1 files changed, 0 insertions, 85 deletions
diff --git a/hardware/basesystem.nix b/hardware/basesystem.nix
deleted file mode 100644
index e5bc5ba..0000000
--- a/hardware/basesystem.nix
+++ /dev/null
@@ -1,85 +0,0 @@
-{
-  config,
-  lib,
-  pkgs,
-  modulesPath,
-  ...
-}: {
-  imports = [
-    (modulesPath + "/installer/scan/not-detected.nix")
-  ];
-
-  boot = {
-    initrd = {
-      availableKernelModules = ["xhci_pci" "nvme" "rtsx_pci_sdmmc"];
-      kernelModules = [];
-      luks.devices."cryptroot".device = "/dev/disk/by-uuid/6700d662-29a9-4ea5-8ca6-85d42550b3ab";
-    };
-    kernelModules = ["kvm-intel"];
-    extraModulePackages = [];
-    kernelPackages = pkgs.linuxPackages_latest;
-    loader = {
-      systemd-boot = {
-        enable = true;
-        configurationLimit = 3;
-      };
-      efi.canTouchEfiVariables = true;
-    };
-  };
-
-  fileSystems = {
-    "/" = {
-      device = "tmpfs";
-      fsType = "tmpfs";
-      options = ["defaults" "size=2G" "mode=755"];
-    };
-    "/nix" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=nix" "compress-force=zstd"];
-    };
-    "/etc/NetworkManager" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=networkmanagerconfig" "compress-force=zstd"];
-    };
-    "/etc/nixos" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=nixconfig" "compress-force=zstd"];
-    };
-    "/srv" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=srv" "compress-force=zstd"];
-    };
-    "/home" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=home" "compress-force=zstd"];
-    };
-    "/srv/snapshots" = {
-      device = "/dev/disk/by-label/nixos-root";
-      fsType = "btrfs";
-      options = ["subvol=snapshots" "compress-force=zstd"];
-    };
-    "/boot" = {
-      device = "/dev/disk/by-uuid/4064-2D6C";
-      fsType = "vfat";
-    };
-  };
-
-  swapDevices = [];
-
-  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
-  # (the default) this is the recommended approach. When using systemd-networkd it's
-  # still possible to use this option, but it's recommended to use it in conjunction
-  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
-  networking.useDHCP = lib.mkDefault true;
-  # networking.interfaces.enp0s31f6.useDHCP = lib.mkDefault true;
-  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
-
-  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
-  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
-}