summary refs log tree commit diff stats
path: root/configuration.nix
diff options
context:
space:
mode:
authorsils <sils@sils.li>2022-12-27 14:17:09 +0100
committersils <sils@sils.li>2022-12-27 14:17:09 +0100
commit72d762fe18152becda950f38f2bf46c76b9bf9f7 (patch)
tree279eeea3a963aa2525652432abe28cab7f510305 /configuration.nix
parentmove desktop options in desktop (diff)
downloadnix-config-72d762fe18152becda950f38f2bf46c76b9bf9f7.tar.gz
nix-config-72d762fe18152becda950f38f2bf46c76b9bf9f7.zip
demodularize
Diffstat (limited to 'configuration.nix')
-rw-r--r--configuration.nix78
1 files changed, 61 insertions, 17 deletions
diff --git a/configuration.nix b/configuration.nix
index 26c138e..f454846 100644
--- a/configuration.nix
+++ b/configuration.nix
@@ -1,20 +1,64 @@
 { config, pkgs, ... }:
-
+	let
+	  compiledLayout = pkgs.runCommand "keyboard-layout" {} ''
+	    ${pkgs.xorg.xkbcomp}/bin/xkbcomp ${./files/neoqwertz.xkb} $out
+	  '';
+	in
 {
-  imports =
-    [ 
-      ./hardware-configuration.nix
-      ./env.nix
-      ./packages.nix
-      ./bootloader.nix
-      ./plasma.nix
-      ./networking.nix
-      ./users.nix
-      ./sound.nix
-      ./cups.nix
-      ./args.nix
-      ./zsh.nix
-      ./keyboard.nix
-    ];
-    system.stateVersion = "23.05";
+	imports = [ 
+		./hardware-configuration.nix
+		./env.nix
+		./packages.nix
+		./users.nix
+		./zsh.nix
+
+		# Desktop Environment to use
+		./desktop/plasma.nix
+	];
+	
+	services = {
+		printing.enable = true;
+		xserver = {
+  			layout = "de";
+  			#xkbVariant = ",neo";
+  			xkbOptions = "grp:win_space_toggle";
+			displayManager.sessionCommands = "${pkgs.xorg.xkbcomp}/bin/xkbcomp ${compiledLayout} $DISPLAY";
+		};
+		pipewire = {
+			enable = true;
+			alsa.enable = true;
+			alsa.support32Bit = true;
+			pulse.enable = true;
+			jack.enable = true;
+		};
+	};
+
+	hardware.bluetooth.enable = true;
+	security.rtkit.enable = true;
+
+	environment.systemPackages = [ pkgs.xorg.xkbcomp ];
+
+	i18n.defaultLocale = "en_US.UTF-8";
+
+	networking = {
+		hostName = "thinklappi";
+		networkmanager.enable = true;
+	};
+
+   	time.timeZone = "Europe/Berlin";
+
+   	console = {
+     		font = "Lat2-Terminus16";
+     		keyMap = "de";
+     		#useXkbConfig = true; # use xkbOptions in tty.
+   	};
+
+	programs.ssh.startAgent = true;
+
+	boot.loader = {
+		systemd-boot.enable = true;
+		efi.canTouchEfiVariables = true;
+	};
+
+	system.stateVersion = "23.05";
 }